System Requirements

To budget with EveryDollar, you'll need a few basic things like an internet connection (broadband is best) and one of the four desktop browsers listed below:

  • Internet Explorer (version 10 or newer) 
  • Google Chrome 
  • Firefox 
  • Safari (version 7 or newer) 
  • Mobile versions of these browsers are not supported 

To budget with EveryDollar on your iPhone, you will need iOS 9.0 or later and an active Wi-Fi or data connection. You can download the app here

To budget with EveryDollar on your Android Phone, you will need OS 4.4 or later and an active Wi-Fi or data connection. You can download the app here.